Comment utiliser la fonction NB.SI sur Excel ?

blog

Bureautique

Excel

Fonction NB.SI

La fonction NB.SI sur Excel

|

10 min

|

Par Hippolyte Le Dem

Vous aimeriez savoir comment compter un nombre de cellules dans une sélection précise sur Excel ? Vous avez entendu parler de la fonction NB.SI mais ne savez pas comment vous en servir ? Vous souhaitez apprendre une nouvelle fonction dans ce logiciel ? Découvrez la fonction NB.SI dans cet article ainsi que différents exemples pour l’illustrer.

Programme formation Excel

+ de 2500 téléchargements

Partager sur :

img test
Testez vos connaissances sur Excel !

Débutant, intermédiaire, avancé ? Passez le test pour connaître votre niveau sur Excel.

Je fais le test

Comment fonctionne la fonction NB.SI ?

La fonction NB.SI est une fonction conditionnelle, comme il en existe de nombreuses autres dans Excel. C’est une fonction dite « multiprise » qui comprend 2 arguments (plage et critère) séparés par un point-virgule dans la formule.


Dans la catégorie des fonctions NB sur Excel, voici un rappel de celles contenant un seul argument (plage) qu’on peut déjà retrouver dans le logiciel :

 

  • « =NB(plage) » pour compter les cellules qui contiennent un nombre ;
  • « =NBVAl(plage) » pour compter les cellules qui sont non-vides ;
  • « =NBVIDE(plage) » pour compter les cellules qui sont vides.

L’avantage de la fonction NB.SI, c’est que vous pourrez être un peu plus précis sur le critère. Cela veut dire qu’une condition va pouvoir être ajoutée pour effectuer le comptage de cellules.

Concrètement, après avoir sélectionné « =NB.SI » dans la cellule à remplir, vous allez pouvoir ajouter la plage (soit sélectionner toutes les cellules concernées par le comptage) ainsi que le critère (ce qui est marqué dans les cellules à compter), séparé par un point-virgule dans la parenthèse. Cela donnera la formule suivante : =NB.SI(plage; critère).

 

Fonction NB.SI sur ExcelFonction NB.SI sur Excel

img test
Maîtrisez Excel de A à Z

Bases du logiciel, détail des fonctions, gestion et analyse de bases de données, tableaux et graphiques croisés dynamiques. 

Découvrir la formation

NB.SI avec des arguments textuels

Si l’argument est textuel, c’est-à-dire que les cellules en question contiennent du texte et non juste un nombre, il faudra bien veiller à l’écrire entre guillemets pour qu’il soit pris en compte dans la formule. Par ailleurs, les comparateurs (supérieur >, inférieur <, différent <> ou encore égal =) sont également considérés comme étant du texte, donc à mettre également entre guillemets.


Vous souhaitez rechercher un élément spécifique sur une plage de cellules comme une lettre en particulier ? Vous pourrez nommer cet élément dans la partie « critère ».

 

Voici des exemples :

  • Pour rechercher la lettre A au début des cellules sélectionnées, il faudra mettre une étoile à la fin de la saisie (exemple : =NB.SI(plage; «A*»)) ;

Fonction NB.SI avec argument textuel sur Excel

  • Pour rechercher la lettre B n’importe où dans les cellules sélectionnées, il faudra mettre une étoile de chaque côté de l’élément (exemple : =NB.SI(plage; «*B*»)) ;
  • Pour rechercher la lettre C à la fin des cellules sélectionnées, il faudra mettre une étoile au début de la saisie (exemple : =NB.SI(plage; «*C»)).

Pour information, l’étoile correspond à une suite d’éléments inconnus qui ne nous intéressent pas pour le calcul de la fonction NB.SI.

Bon à savoir

Concernant les arguments textuels, sachez qu’Excel n’est pas sensible à la « casse ». Cela veut dire que votre formule fonctionne, que vous écriviez votre texte en majuscule ou en minuscule. En revanche, il est indispensable de faire attention aux accents qui eux sont pris en compte dans le calcul de la fonction Excel. 

Si cela vous paraît compliqué, sachez que nous proposons une formation Excel en ligne dont l’objectif est de vous aider à développer rapidement des compétences sur ce logiciel. 

NB.SI avec l'argument différent de

Si vous souhaitez calculer le nombre de cellules ne contenant pas un critère spécifique, vous devrez utiliser le comparateur « différent de », écrit comme ceci : « <> ». Comme on l’a vu plus haut, ces éléments devront aussi être placés entre guillemets car les comparateurs sont considérés comme du texte.

Exemple

Si vous voulez compter le nombre de cellules ne contenant pas le chiffre 3, vous devrez écrire la formule suivante : =NB.SI(plage; «<>3 »). Le chiffre 3 peut bien évidemment être remplacé par du texte si l’on souhaite exclure les cellules contenant un terme précis.

img test
Formations Bureautique

Formation Excel, formation Word, formation PowerPoint et formation outils collaboratifs. Toutes nos formations sont éligibles au CPF.

Découvrir les formations

NB.SI avec un critère pointé dans une cellule

Avec la fonction NB.SI, il est aussi possible de sélectionner une cellule spécifique de la feuille de calcul pour récupérer une information du tableau initial en guise de critère.

Exemple

Par exemple, si vous souhaitez compter toutes les cellules contenant le mot « fruit » dans votre tableau initial et que ce mot se trouve en « F5 » dans un second tableau dédié au calcul de cellules, vous pourrez entrer cette formule : =NB.SI(plage; F5). Vous pourrez alors trouver combien de cellules de votre tableau initial comporte le mot « fruit ». Lorsque vous intégrez des coordonnées de cellules dans vos formules, vous n’avez pas besoin de guillemets.

Fonction NB.SI avec critère pointé vers une cellule sur ExcelFonction NB.SI avec critère pointé vers une cellule sur Excel

💡 Pour gagner du temps dans le calcul de vos cellules en recherchant différents termes, vous pouvez utiliser la méthode du « copier-glisser » dans votre second tableau de cette façon :

 

  1. Placez le signe « $ » pour bloquer la plage de cellules de sélectionnée et éviter qu‘elle ne se déplace vers le bas. Par exemple, si la plage sur laquelle vous recherchez le mot « fruit » se trouve de B5 à B10, vous devrez taper comme formule =NB.SI($B$5:$B$10; F3) ;
  2. Ensuite, faites simplement glisser la formule aux cellules du dessous pour l’appliquer aux autres termes recherchés dans la plage de cellules en question. Par exemple, si vous recherchez le terme « légumes » qui se trouve en F4 dans votre second tableau, vous obtiendrez alors =NB.SI($B$5:$B$10; F4) grâce au « copier-glisser ». Cette technique vous permet d’obtenir des résultats justes et rapides.

NB.SI avec un critère variable

La fonction NB.SI peut également permettre des calculs avec un critère variable. Il peut notamment servir à dédoublonner une base de données de façon plus précise. En effet, si cette fonctionnalité existe déjà dans Excel, elle offre malheureusement peu de détails sur les types de doublons qui ont été enlevés. Pour obtenir des résultats plus fins, vous allez donc pouvoir utiliser la fonction NB.SI avec un critère variable.

img test
TOSA Excel, qu'est-ce que c'est ?

Découvrez comment passer la certification Excel.

Lire l'article


Si l’on souhaite compter le nombre de cellules comportant un mot identique dans l’ensemble de la plage et appliquer ce critère à l’ensemble d’une liste de mots, il va falloir recourir à la même méthode que celle vue précédemment. Nous allons prendre un exemple. Imaginons que vous souhaitez compter le nombre de personnes avec le nom de famille « PETIT » dans la liste contenue dans votre plage de cellules allant de B2 à B17. La première cellule avec ce nom de famille est B2. 


Vous devrez alors utiliser la formule suivante : =NB.SI($B$2:$B$17;B2). Cela vous permettra de savoir combien de fois le nom de famille « PETIT » apparaît dans votre liste. Il vous suffira ensuite de copier et glisser cette formule vers le bas, afin de connaître le nombre de doublons pour chaque nom de famille de cette plage de données.

 

Fonction NB.SI avec un critère variable sur ExcelFonction NB.SI avec un critère variable sur Excel

 

Avec la fonction NB.SI sur Excel, vous devriez donc pouvoir effectuer bon nombre de calculs utiles dans votre quotidien personnel et professionnel. S’il vous faut un accompagnement plus approfondi sur les fonctions, nous vous recommandons de suivre une formation Excel dispensée par Walter Learning. Vous y trouverez toutes les réponses aux questions que vous vous posez sur les fonctions Excel, des plus simples aux plus avancées. Vous pouvez également lire nos articles sur la fonction SOMME.SI et la fonction SI sur Excel. N’hésitez pas à prendre contact avec notre équipe pour en savoir plus. Nous proposons également des cours sur les autres logiciels de la Suite Office de Microsoft.

Téléchargez le programme de la formation Excel en PDF

Programme formation Excel

Programme formation Excel

+ de 2500 téléchargements

Programme formation Excel

+ de 2500 téléchargements

Envie d’en savoir plus sur Excel ?

Besoin de devenir expert(e) d’Excel rapidement ? Découvrez gratuitement notre formation !

Demo image
Demander une démo

Partager sur :

Commentaires

Publier un commentaire

Un doute, une question, nous vous répondrons dans les meilleurs délais.

Sur le même thème

Fonctions EQUIV et INDEX sur Excel : définition et utilisation

Walter Learning

Hippolyte Le Dem

|

13 Mars 2023

Chapitre phare de toute formation Excel, les fonctions vous offrent une multitude de possibilités. Celles-ci peuvent cependant s’avérer difficiles à comprendre, particulièrement lorsqu’elles s’assemblent. Dans cet article, découvrez comment utiliser les fonctions INDEX et EQUIV d’Excel à bon escient. Comment se présente leur syntaxe ? Quels arguments sont indispensables et pour quelles situations ? Nous évoquons la structure de ces fonctions, leur mode d’emploi, mais aussi les avantages non négligeables de créer une formule Excel combinant INDEX et EQUIV.

Lire l'article

Utilisation et syntaxe de la fonction MAX sur Excel

Walter Learning

Hippolyte Le Dem

|

13 Mars 2023

Dans cet article, apprenez à utiliser la fonction MAX d’Excel. Nous vous expliquons à quoi elle sert et comment elle se construit, avant de vous proposer un exemple concret. La formule MAX est incontournable et évoquée dans toute .

Lire l'article

Comment suivre une formation Excel pour débutant ?

Walter Learning

Hippolyte Le Dem

|

16 Janvier 2023

Vous voulez apprendre les fonctionnalités basiques du tableur Excel ? Apprendre à faire « parler les chiffres », c’est maîtriser les bases d’Excel, Les formations Excel pour débutant offrent cette compétence. Certains cours sur les bases d’Excel sont disponibles au sein de formation Excel en ligne destinées aux débutants.

Lire l'article

Maîtrisez les fonctions financières sur Excel

Walter Learning

Hippolyte Le Dem

|

8 Août 2022

Vous recherchez des informations sur une fonction Excel en particulier ? Les fonctions financières sur Excel vous sont encore inconnues ? Vous aimeriez apprendre à utiliser Excel rapidement ? 
Bonne nouvelle : dans cet article, nous allons vous donner plusieurs astuces pour effectuer des calculs dans le cadre d’un prêt bancaire ou d’une assurance-vie. Vous découvrirez quelles sont les 5 fonctions financières d’Excel les plus courantes ainsi que plusieurs exemples d’application avec la fonction VPM, la fonction VC et enfin la fonction TAUX.

Lire l'article