blog

Bureautique

Fonction NB.SI

Comment utiliser la fonction NB.SI sur Excel

Hippolyte Le Dem

Co-fondateur de Walter

|

Vous aimeriez savoir comment compter un nombre de cellules dans une sélection précise sur Excel ? Vous avez entendu parler de la fonction NB.SI mais ne savez pas comment vous en servir ? Vous souhaitez apprendre une nouvelle fonction dans ce logiciel ? Découvrez la fonction NB.SI dans cet article ainsi que différents exemples pour l’illustrer.

img test
Maîtrisez Excel de A à Z

Notre formation en ligne complète : bases du logiciel, détail des fonctions, gestion et analyse de bases de données, tableaux et graphiques croisés dynamiques. Leçons et exercices.

Découvrir la formation

Comment fonctionne la fonction NB.SI ?

La fonction NB.SI est une fonction conditionnelle, comme il en existe de nombreuses autres dans Excel. C’est une fonction dite « multiprise » qui comprend 2 arguments (plage et critère) séparés par un point-virgule dans la formule.


Dans la catégorie des fonctions NB sur Excel, voici un rappel de celles contenant un seul argument (plage) qu’on peut déjà retrouver dans le logiciel :

 

  • « =NB(plage) » pour compter les cellules qui contiennent un nombre ;
  • « =NBVAl(plage) » pour compter les cellules qui sont non-vides ;
  • « =NBVIDE(plage) » pour compter les cellules qui sont vides.

L’avantage de la fonction NB.SI, c’est que vous pourrez être un peu plus précis sur le critère. Cela veut dire qu’une condition va pouvoir être ajoutée pour effectuer le comptage de cellules.


Concrètement, après avoir sélectionné « =NB.SI » dans la cellule à remplir, vous allez pouvoir ajouter la plage (soit sélectionner toutes les cellules concernées par le comptage) ainsi que le critère (ce qui est marqué dans les cellules à compter), séparé par un point-virgule dans la parenthèse. Cela donnera la formule suivante : =NB.SI(plage; critère).

 

Fonction NB.SI sur ExcelFonction NB.SI sur Excel

NB.SI avec des arguments textuels

Si l’argument est textuel, c’est-à-dire que les cellules en question contiennent du texte et non juste un nombre, il faudra bien veiller à l’écrire entre guillemets pour qu’il soit pris en compte dans la formule. Par ailleurs, les comparateurs (supérieur >, inférieur <, différent <> ou encore égal =) sont également considérés comme étant du texte, donc à mettre également entre guillemets.


Vous souhaitez rechercher un élément spécifique sur une plage de cellules comme une lettre en particulier ? Vous pourrez nommer cet élément dans la partie « critère ».

 

Voici des exemples :

  • Pour rechercher la lettre A au début des cellules sélectionnées, il faudra mettre une étoile à la fin de la saisie (exemple : =NB.SI(plage; «A*»)) ;

Fonction NB.SI avec argument textuel sur Excel

  • Pour rechercher la lettre B n’importe où dans les cellules sélectionnées, il faudra mettre une étoile de chaque côté de l’élément (exemple : =NB.SI(plage; «*B*»)) ;
  • Pour rechercher la lettre C à la fin des cellules sélectionnées, il faudra mettre une étoile au début de la saisie (exemple : =NB.SI(plage; «*C»)).

Pour information, l’étoile correspond à une suite d’éléments inconnus qui ne nous intéressent pas pour le calcul de la fonction NB.SI.

Bon à savoir

Concernant les arguments textuels, sachez qu’Excel n’est pas sensible à la « casse ». Cela veut dire que votre formule fonctionne, que vous écriviez votre texte en majuscule ou en minuscule. En revanche, il est indispensable de faire attention aux accents qui eux sont pris en compte dans le calcul de la fonction Excel. 

Si cela vous paraît compliqué, sachez que nous proposons une formation Excel en ligne dont l’objectif est de vous aider à développer rapidement des compétences sur ce logiciel. 

img test
Maîtrisez Excel de A à Z

Notre formation en ligne complète : bases du logiciel, détail des fonctions, gestion et analyse de bases de données, tableaux et graphiques croisés dynamiques. Leçons et exercices.

Découvrir la formation

NB.SI avec l'argument différent de

Si vous souhaitez calculer le nombre de cellules ne contenant pas un critère spécifique, vous devrez utiliser le comparateur « différent de », écrit comme ceci : « <> ». Comme on l’a vu plus haut, ces éléments devront aussi être placés entre guillemets car les comparateurs sont considérés comme du texte.

Exemple

Si vous voulez compter le nombre de cellules ne contenant pas le chiffre 3, vous devrez écrire la formule suivante : =NB.SI(plage; «<>3 »). Le chiffre 3 peut bien évidemment être remplacé par du texte si l’on souhaite exclure les cellules contenant un terme précis.

NB.SI avec un critère pointé dans une cellule

Avec la fonction NB.SI, il est aussi possible de sélectionner une cellule spécifique de la feuille de calcul pour récupérer une information du tableau initial en guise de critère.

Exemple

Par exemple, si vous souhaitez compter toutes les cellules contenant le mot « fruit » dans votre tableau initial et que ce mot se trouve en « F5 » dans un second tableau dédié au calcul de cellules, vous pourrez entrer cette formule : =NB.SI(plage; F5). Vous pourrez alors trouver combien de cellules de votre tableau initial comporte le mot « fruit ». Lorsque vous intégrez des coordonnées de cellules dans vos formules, vous n’avez pas besoin de guillemets.

Fonction NB.SI avec critère pointé vers une cellule sur ExcelFonction NB.SI avec critère pointé vers une cellule sur Excel

 

💡 Pour gagner du temps dans le calcul de vos cellules en recherchant différents termes, vous pouvez utiliser la méthode du « copier-glisser » dans votre second tableau de cette façon :

 

  1. Placez le signe « $ » pour bloquer la plage de cellules de sélectionnée et éviter qu‘elle ne se déplace vers le bas. Par exemple, si la plage sur laquelle vous recherchez le mot « fruit » se trouve de B5 à B10, vous devrez taper comme formule =NB.SI($B$5:$B$10; F3) ;
  2. Ensuite, faites simplement glisser la formule aux cellules du dessous pour l’appliquer aux autres termes recherchés dans la plage de cellules en question. Par exemple, si vous recherchez le terme « légumes » qui se trouve en F4 dans votre second tableau, vous obtiendrez alors =NB.SI($B$5:$B$10; F4) grâce au « copier-glisser ». Cette technique vous permet d’obtenir des résultats justes et rapides.

 

img test
TOSA Excel, qu'est-ce que c'est ?

Découvrez comment passer la certification Excel.

Lire l'article

NB.SI avec un critère variable

La fonction NB.SI peut également permettre des calculs avec un critère variable. Il peut notamment servir à dédoublonner une base de données de façon plus précise. En effet, si cette fonctionnalité existe déjà dans Excel, elle offre malheureusement peu de détails sur les types de doublons qui ont été enlevés. Pour obtenir des résultats plus fins, vous allez donc pouvoir utiliser la fonction NB.SI avec un critère variable.


Si l’on souhaite compter le nombre de cellules comportant un mot identique dans l’ensemble de la plage et appliquer ce critère à l’ensemble d’une liste de mots, il va falloir recourir à la même méthode que celle vue précédemment. Nous allons prendre un exemple. Imaginons que vous souhaitez compter le nombre de personnes avec le nom de famille « PETIT » dans la liste contenue dans votre plage de cellules allant de B2 à B17. La première cellule avec ce nom de famille est B2. 


Vous devrez alors utiliser la formule suivante : =NB.SI($B$2:$B$17;B2). Cela vous permettra de savoir combien de fois le nom de famille « PETIT » apparaît dans votre liste. Il vous suffira ensuite de copier et glisser cette formule vers le bas, afin de connaître le nombre de doublons pour chaque nom de famille de cette plage de données.

 

Fonction NB.SI avec un critère variable sur ExcelFonction NB.SI avec un critère variable sur Excel

 

Avec la fonction NB.SI sur Excel, vous devriez donc pouvoir effectuer bon nombre de calculs utiles dans votre quotidien personnel et professionnel. S’il vous faut un accompagnement plus approfondi sur les fonctions, nous vous recommandons de suivre une formation Excel dispensée par Walter Learning. Vous y trouverez toutes les réponses aux questions que vous vous posez sur les fonctions Excel, des plus simples aux plus avancées. Vous pouvez également lire nos articles sur la fonction SOMME.SI et la fonction SI sur Excel. N’hésitez pas à prendre contact avec notre équipe pour en savoir plus. Nous proposons également des cours sur les autres logiciels de la Suite Office de Microsoft.

img test
Formations Bureautique

Formation Excel, formation Word, formation PowerPoint et formation outils collaboratifs. Toutes nos formations sont éligibles au CPF.

Découvrir les formations

Sur le même thème

Comment obtenir la certification TOSA Excel ?

Hippolyte Le Dem

|

12 Janvier 2022

Vous cherchez à mettre en valeur vos compétences en informatique, plus particulièrement celles sur ? Véritable boost de carrière, passez la certification Excel pour connaître votre niveau et le partager à votre futur employeur ou votre manager. Pour vous préparer au mieux, il est important de suivre en amont une formation TOSA Excel. Découvrez tout ce qu'il y a à savoir sur cette certification bureautique. 

Lire l'article

L'impression sur Excel

Hippolyte Le Dem

|

27 Juin 2022

L’impression fait partie des notions à connaître quand on veut se former à Excel ou à tout autre logiciel de bureautique. Cette notion est fondamentale au même titre que la maîtrise des feuilles de calcul. Vous devez pouvoir présenter des tableaux Excel imprimés avec une bonne présentation sans soucis de mise en page. Découvrez comment maîtriser les options les plus courantes dans l’impression Excel.

Lire l'article

La fonction RECHERCHEV sur Excel

Hippolyte Le Dem

|

8 Août 2022

Il est normal de se demander quand on a un niveau débutant sur ce logiciel. Maîtriser les fonctions Excel ne s’invente pas, c’est pourquoi nous vous proposons quelques astuces dans nos différents articles sur le sujet. Pour l’heure, nous allons vous présenter la fonction RECHERCHEV et vous expliquer son utilisation via des exemples concrets.

Lire l'article

Comment gérer l'affichage de l'onglet Excel ?

Hippolyte Le Dem

|

27 Juin 2022

Les onglets Excel sont une fonctionnalité très utile du logiciel, mais leur utilisation est souvent peu claire quand elle n’est pas entièrement maîtrisée. Voici un tour d’horizon de l'affichage de l'onglet Excel pour savoir . 

Lire l'article